`

湖南师范大学OJ-10021

    博客分类:
  • ACM
J# 
阅读更多
Lowest Bit 
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB 
Total submit users: 22, Accepted users: 22 
Problem 10021 : No special judgement 
Problem description
  Given an positive integer A (1 <= A <= 10^9), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.



Input
  Each line of input contains only an integer A (1 <= A <= 109). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output
  For each A in the input, output a line containing only its lowest bit.


Sample Input
26
8
0

Sample Output
2
8



import java.util.Scanner;


public class Acm10021 {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		Integer a = cin.nextInt();
		String binaryNum = null;
		String suffixNum = null;
		int result;
		while(a != 0){
			result = 0;
			binaryNum = new String();
			binaryNum = Integer.toBinaryString(a);
			suffixNum = new String();
			suffixNum = binaryNum.substring(binaryNum.lastIndexOf("1"), binaryNum.length());
			int j=0;
			for(int i=suffixNum.length(); i>0; i--){
				result += Integer.parseInt(suffixNum.substring(i-1, i))*Math.pow(2, j);
				j++;
			}
			System.out.println(result);
			a = cin.nextInt();
		}
	}
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics